Backup forum

A place to discuss Backup software and online services

You are not signed in.

Announcement

Hot Tags: account Android Archive cleanup Backup bug bugs cleanup CPU Delete desktop error fail failed failure feature request idevsutil iDrive incremental internet issue linux log login mac Mobile password performance progress QNAP REST restore Security slow speed suggestions sync Synology upgrade upload windows backblaze carbonite SugarSync Dropbox Veeam Netgear Asustor Pro Softnet Corporation

#1 2018-06-17 14:32:34

Mouse
Member
Registered: 2018-05-18
Posts: 17

B/U of some files fails w. 'file open' error, though open file B/U on

1. What actually happened [+Idrive ID]
Backup of some open files such as Outlook.pst, Vmware .log files, and bespoke Word template .dotx files, consistently fails with 'Failed to read the file; It is either open or locked' error in detailed log, even though open files backup is switched on in Idrive client settings. [ID292711772]
Log entries:
[Error] [06/15/2018 23:12:13] [D:\.....\Outlook.pst] [Failed to read the file; It is either open or locked]
[Error] [06/15/2018 23:12:13] [D:\......\My Virtual Machines\CentOS 7 64-bit minimal under Centos - try 3\vprintproxy.log] [Failed to read the file; It is either open or locked]
[Error] [06/15/2018 23:12:13] [D:\.......\My Virtual Machines\CentOS 7 64-bit minimal under Centos - try 3\vmware.log] [Failed to read the file; It is either open or locked]
[Error] [06/15/2018 23:12:13] [D:\........\Spec ..... template.dotx] [Failed to read the file; It is either open or locked]


2. What you did to cause that to happen, step by step
i) Make sure Outlook 2010 is open with a .pst file loaded, Vmware is running a virtual machine, and Word has a document with a bespoke template loaded
ii) Request a scheduled backup via the scheduler
iii) Examine the logs after the backup is completed

3. If you repeat these steps does the same thing always happen
Almost always, yes

4. What you expected or wanted to happen
No errors in the log, open files are backed up sucessfully

5. Operating system, whether 32 or 64bit, and service pack number
Windows 7 Ultimate, 64bit

6. Idrive full version number
6.7.1.21

7. Any backup, security, or sandbox software installed now or previously
Yes Comodo CCAV, formerly Comodo CCS/CIS. Windows backup. Comodo Backup (client not loaded).

8. Current Idrive settings (redacted for privacy if appropriate)
https://dl.dropboxusercontent.com/s/vnqzsuz31r57wsh/k-meleon_2018-06-17_14-18-47.png
https://dl.dropboxusercontent.com/s/yfb8hhz0ee4x9ws/k-meleon_2018-06-17_14-19-49.png

Whether backup was online or offline
Online

9. Any other relevant information (eg Your guess at the reason for the bug, how you have tried to fix or analyse it)
I tried backing up with programs closed, this was successful
I tried copying the same files when open using a shadow copy utility which uses the same OS service as Idrive - this was sucessful
http://www.runtime.org/shadow-copy.htm
I used lockhunter utility to check for locks on the open files. The Outlook file was not locked, but the Vmware files were. Locks should not prevent shadow copy though.
www.lockhunter.com

Last edited by Mouse (2018-06-17 16:28:09)

Offline

 

Board footer

UptimeRobot Web Site Monitoring Service Stop Forum Spam

Powered by © Copyright 2002–2005 Rickard Andersson
SteveA's forums are free for everyone to use, however if you would like to contribute to the upkeep I would be grateful for any donation!